Jump to content

Mazda gearboxes....... (some b'stard told me it was impossible so I had to do it!)


Recommended Posts

I pretty much made a flange yesterday to serve as a spacer.

Meanwhile, Triumphs rather odd construction methods have come to my rescue. Not entirely sure why the joint is sleeved like this.......

1A8201A9-BB70-441E-8ED5-781865809B25.jpeg

.......but dead easy to cut around the outer pipe freeing the inner one to drop down a little. In fact, the small amount of angle correction it allows does nearly all - very little actual drop needed.

  • Like 1
Link to post
Share on other sites
  • Replies 179
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Have now finished the adapter ring. Quite happy with the way it turned out. There was a certain amount of fettling required for the final fit but once that was done it dropped into place nicely - and,

Hello Nick                  How about a stretched limo look? The Satnav had locked onto this? but the view was worth it and me and the Memsahib had a nice picnic and a nice ice-cream on the

Run out of excuses to put it in properly..... quick photo line-up first though Our victim is the one in the middle.... It then got wrestled into place (I'm getting better at i

Posted Images

1 hour ago, Nick Jones said:

Meanwhile, Triumphs rather odd construction methods have come to my rescue. Not entirely sure why the joint is sleeved like this.......

Hello Nick

                 Exhausts on some motorcycles were done like that to keep the heat down and so stop the chromium plating for blueing so much.

Triumph may have done it to stop that part getting so hot but maybe for strength 

Roger 

Link to post
Share on other sites
1 hour ago, Nick Jones said:

Meanwhile, Triumphs rather odd construction methods have come to my rescue. Not entirely sure why the joint is sleeved like this.......

Did you discover this by starting to cut?! If so, that's handy :)

I need to get about 1/2 inch extra on my FWD exhaust so this is an interesting development. I wonder if it's made the same way. 

Link to post
Share on other sites
33 minutes ago, PeteStupps said:

Did you discover this by starting to cut?! If so, that's handy

No, you can see it's welded in two places on the outside and that there are two different diameters.  Inside you can see there are two tubes, one inside the other.  The inner one was actually slight proud out the outer before I started and the outer is 11mm proud of the flange

IMG_5656s.jpg

I was slow to spot the potential of this arrangement and had been considering trying to bend it - with great reluctance as slightly rusty and already much bent exhaust tube sometimes just breaks - and I've snapped a cast-iron manifold off with similar antics once before. 

 

 

 

  • Like 1
Link to post
Share on other sites
48 minutes ago, rogerguzzi said:

 Exhausts on some motorcycles were done like that to keep the heat down and so stop the chromium plating for blueing so much.

Interesting.  No chrome here though. Just rusty mild steel.  Possibly it's done like this just to make it easier to jig and weld to angles and orientation right.  It hadn't worked though, orientation was slightly out and I had to file the holes when I fitted it the first time.

Link to post
Share on other sites

In amongst all this, I unexpectedly had a bit of labour available meaning it was time to drop out the rear spring and diff.

The spring because the car has been sitting too low at the back and the exhaust clamps are getting ground down.  Ian, (GT64Fun on here), had had a similar problem on his car some years back and had an extra spring leaf made to beef it up a bit.  It worked a treat.  Far-sighted fellow that he is, he had two made and very generously donated his spare one to me.

So the spring was wrestled out and dismantled.  Was actually in pretty fair looking shape which is why I left it alone in the original rebuild

IMG_5627s.jpg

IMG_5628s.jpg

All given a bit of a scrape and a wire-brushing before reassembly with some nice sticky grease.  I had to make a new centre bolt as the original was too short.  The strap bolts didn't fit any more either due to the extra leaf and after pondering ways to deal with that it occurred to me that I could see absolutely no purpose for them them.  So I left 'em out.  If anyone has any good reasons why this is a bad idea... best let me know!

The diff was an unknown 3.63 I took out of a scrapped 1500 Spit some years back.  I'd fitted new seals and side shaft bearings but otherwise left it alone as it seemed quite good.  However, it leaks fairly badly from the pinion seal and is rather noisy so I thought I sling the previous Vitesse 3.63 in there  as I'm fairly sure its less noisy.

Not my favourite job but got it out and the replacement in without great drama.  Has some difficulty getting the spring-eye bolts back in as the spring was noticeably perkier and we were picking the car off the axle stands.....

We shall see how it goes when I get to drive the thing finally but I'm fairly hopeful.

Link to post
Share on other sites

So, welded up the exhaust after tacking it in situ.  Then got a bit carried away and fitted the whole system.  Managed to get it fitting much better this time though not quite sure how/why.

This meant I had run out of displacement activities to defer revisiting the clutch conundrum.  Had one more bleed attempt and did get a few bubbles.  Made no difference though.  Was puzzled as I could feel the clutch going over centre about 2/3 down the stroke and that is normally where they disengage....

Broke out a big spanner and tried turning the engine over.  It did turn and didn't feel noticeably stiffer that usual.

So I fitted the 0.7" M/C and bled it.  Now the pedal is heavier and I can feel the clutch going over centre about 1/3 down.  Still doesn't release fully though.  Odd.:confused:

At this point I decided to refit the starter and fire the engine up.  After pausing long enough to put oil in the gearbox came moment of truth #1.  Unlike the Vitesse which always starts on the 3rd compression stroke whether she's been off 3 minutes or 3 months, this took some cranking and some popping and farting.  Then when she did fire up there was the most appalling screeching from the bell housing. :pinch:

Unmistakeably something rotating running against something stationary, without the benefit of a bearing..... unaltered by clutch pedal position and still no clutch release. Turn off immediately. Crawl underneath expecting to find vitals fluids dribbling out - but there are none.  Peer into the bell housing expecting to find shavings and shrapnel.... nothing.  Which is good.... but what... the ... flip.... is going on?:wacko:

After some serious thinking I conclude that it has to be the internal guide tube of the CSC making contact with the central splined boss of the friction plate and as well as making the dire noises it is also responsible for keeping the friction plate pressed against the flywheel.  This is unexpected as I did consider/measure this and reckoned I had 4mm spare at the most pessimistic measuring.  Couldn't be by much as when the gearbox was fitted to the engine it slipped straight on unusually sweetly (clutch alignment tool worked!) and appeared to go all the way.  It then occurred to me that I'd taken the measurements using the Triumph clutch plate as at that point I didn't have the Mazda one.  I had meant to re-check when I did the final fit check with the Mazda clutch on the spare engine but didn't actually do it..... Oops.....  Must be a chunkier boss....

To prove it I found some 2mm alu sheet and made some shim strips to drop in over the top three bell-housing studs and also the bottom 2.  Release all BH bolts a bit and use the clutch pedal to ease the box back enough to get the strips in.  Nip up top and bottom bolts...... and the clutch now releases perfectly....

So the correct thing to do at this point would be to pull the box back out and machine the friction plate boss (or at least introduce it to Mr Grinder)..... but.... that's a huge effort and there might be other issues.

So instead I spent a couple of hours making some really nice 2mm shim plates to go around the engine/BH joint so everything is fully supported and put in all the bolts and did them up.  I'm calling it a "field solution" and it's temporary....ish.:whistling:

Moment of truth #2: Fire the engine up again and no nasty noises.  The clutch works and I can get all the gears and if I lift the pedal the wheels turn.  We have a working driveline again.

Time to fit a drivers seat :blink:

Link to post
Share on other sites

All getting quite exciting.

Leaf clips obviously keep the leaves aligned but not sure the bolts do much with the spring on the car

Providing that is the leaves ate kept loaded. You may find them rattling on bumps without the bolts in.

Can't remember if the Vitesse spring has the rubber buttons or not. If so then these could bounce out

Link to post
Share on other sites

I got the seat bolted in and the car down off the stands, but then ran out of day and energy.  It was raining too.

So as today dawned brighter and less rainy, it became the day of truth... or moment of truth #3.

Engine fires up much more happily, engage reverse and back out of the garage.  Oops, forgot mobile phone - that might be over-confident!

Phone collected I set out.  Impressions are that the driveline feels nice and taut, no clunks or undue backlash. 

Gearchange is sweet, as is the clutch action.  Biting point is on the high side (some idiot changed the M/C for a bigger one!) but acceptable.  Gearbox seems rather noisy in 1 - 3, but then it did cost a whole £ 30 from ebay and anyway........

IMG_5666s.jpg

..........there's no tunnel cover, so I'm practically sat on it!  Ratios are ok.  1st is noticeably lower than standard and there's a bit of a step up to second, then second third and fourth are nice and close.

The speedo is wildly pessimistic, but does work smoothly.  I knew it would need recalibration.  6 miles of windy B road, and a town.  I had intended to turn around before the town but it's driving so normally I carry on, then rashly venture out onto the A303 to make a loop. It's fine.  Cruises at 3000 rpm (70ish) without vibration.  Fairly loud with no tunnel though!  Rides nicely at the back end and I can't hear the diff..... which means little given the other racket.

Made it home without drama.  I'm calling it a win.  I will refit the the tunnel once I've made a new bolt -in floor section and have another run out.  I'm inclined to run it through the summer now and see what arises.  If all goes well I'll revisit in the autumn to properly sort the contact issue and perhaps swap the modded parts onto one of my spare 'boxes....

To be continued but I'm getting there at last :smile:

 

IMG_5667s.jpg

Link to post
Share on other sites
7 minutes ago, Escadrille Ecosse said:

Providing that is the leaves ate kept loaded

There's a fair amount of tension on there even at full droop, I doubt it'll be an issue.  There are rubber buttons, though they are a bit worn.

  • Like 1
Link to post
Share on other sites

That is excellent bit of work. 

Gearbox always seems ridiculously liad without the tunnel cover.

Once bought a scrapper GT6 Spitfire conversion. Replaced the front upright and drove it the 10 miles home.

No tunnel cover and the exhaust stopped under the gearbox. :ohmy:

That was LOUD.

Probably also fortunate that it had not soft top so I didn't die as a consequence of CO poisoning 

Link to post
Share on other sites
6 minutes ago, Escadrille Ecosse said:

Probably also fortunate that it had not soft top so I didn't die as a consequence of CO poisoning 

True dat.....

I once drove the Vitesse with no tunnel cover on having just rebuilt a Triumph box for it.  In those days I was unaware that Triumph used different helix angles in different years.  It was quite noisy spinning in neutral.  Under load it was ear-splitting.  Had to do that one again.....

  • Haha 1
Link to post
Share on other sites
2 minutes ago, Nick Jones said:

True dat.....

I once drove the Vitesse with no tunnel cover on having just rebuilt a Triumph box for it.  In those days I was unaware that Triumph used different helix angles in different years.  It was quite noisy spinning in neutral.  Under load it was ear-splitting.  Had to do that one again.....

It is said that if a job's worth doing, it's worth doing twice.

Still painful though...

Link to post
Share on other sites
1 hour ago, Nick Jones said:

To be continued but I'm getting there at last :smile:

Bloody well done! Very pleased to read the last few posts Nick, I doff my metaphorical hat in your direction. 

Link to post
Share on other sites

Thanks Pete. Don’t know if I can claim a first/only with this, but I doubt there are many out there . It’s too bloody hard and most people have more sense!

If Vitesse Transmissions really can come up with a kit that “just bolts in”, they will have done extremely well. But you will have to pull the engine to fit it - or cut the floor.

Link to post
Share on other sites
19 hours ago, Nick Jones said:

The strap bolts didn't fit any more either due to the extra leaf

Hi Nick

I must have forgotten to mention that I slotted the straps to get them to fit....sorry!

Well done with the gearbox progress. +1 for the 'metaphorical hat doffing'. Sounds as though it will all have been worth it.

Ian

Link to post
Share on other sites
21 hours ago, Nick Jones said:

True dat.....

I once drove the Vitesse with no tunnel cover on having just rebuilt a Triumph box for it.  In those days I was unaware that Triumph used different helix angles in different years.  It was quite noisy spinning in neutral.  Under load it was ear-splitting.  Had to do that one again.....

On a Dolomite 1850,
having fitted a T9 gearbox I thought a test drive BEFORE refitting the tunnel
cover was necessary. All was fine except that I just wrapped the exhaust
manifold and front pipe......


 

 

........it was a touch smokie

 

Ian

Link to post
Share on other sites
2 hours ago, Gt64fun said:

I must have forgotten to mention that I slotted the straps to get them to fit....sorry!

I think you did mention it. I wasn’t convinced there was enough strap there to slot without falling out of the end. Doesn’t seem to be causing a problem and the ride height is now much more sensible - so thank you very much for the leaf. I suspect every Roto GT6 needs one :smile:

Link to post
Share on other sites
48 minutes ago, Sprint95m said:

On a Dolomite 1850,
having fitted a T9 gearbox I thought a test drive BEFORE refitting the tunnel
cover was necessary. All was fine except that I just wrapped the exhaust
manifold and front pipe......


 

 

........it was a touch smokie

 

Ian

Oh er!!

Link to post
Share on other sites

In keeping with the general laws of everything being more awkward than expected, today I went to pop the tunnel on so I could have a proper measure up for the new floor section.  But it doesn't fit any more.....

Took me a while to realise that the offender is the reversing light switch, which wasn't present when I've previously tried the tunnel on.  It's a fairly massive 30mm deep plus wires and in a fairly prominent position at about 10 o clock.  It also lines up disappointingly well with the H frame position which means a simple power-bulge won't work.  Bah! (Again!)

I spent a bit of time on line looking to see if there was a more compact version of the switch.  There may well be but not listed under MX5.  I could just plug the hole and make other arrangements for the switch.  I'd rather not.....

Link to post
Share on other sites

The offending switch.....

57234BD1-0D74-457B-8FAA-399AABDDF954.jpeg

Still not sure what to do about it. Ironically, the hex head object to the right is my reverse selection discourager plunger (a purpose it doesn’t serve very well), and is perfectly placed to serve as a reverse light switch..... apart from the fact that it isn’t a switch. Obviously the thread and length are entirely different from the actual switch.

When I did the W58 conversion on the Vitesse, at this stage of the game, I benefited from a bit of serendipity. Stuff like the speedo gearing matching Triumphs and the reversing light switch plugging straight into existing wiring, and nothing trying to poke through the tunnel cover. Seems it’s payback time!

 

Link to post
Share on other sites
1 hour ago, rogerguzzi said:

Is it deeper than the Lucas one with the lucars that are flat?

I would say so, yes.  Not wishing to mess with the casing at this point - don't want to pull the box and dismantle.

Link to post
Share on other sites
  • Nick Jones changed the title to Mazda gearboxes....... (some b'stard told me it was impossible so I had to do it!)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...