Jump to content

Recommended Posts

Accel enrichment can play up if you have noise on the TPS signal or a spikey MAP (depends which of the various strategies you have activated)  but it is a fairly troublesome subject anyway.  You can tell it is a PITA subject as they are MANY variations across the different versions of the firmware!  The problem I always had was getting rid of a slight off-idle stumble - helps just to keep the map slightly richer in the relevant area.

 

RV8s have a tendency to problems with their hydraulic cam followers (and eating of cam lobes) which may explain your knock?

 

Nick

Share this post


Link to post
Share on other sites

A small update as to what is happening with the car as it is off the road for now and may be off the road for a while as the car has developed a starting problem ( as in it will not start ).

 This started about 7 weeks ago as one day the car decided out of the blue not to start or when I could get it started it ran like a pig and kept fouling it's plugs, so in due diligence the plugs and leads where changed to no effect, all the settings where checked to make certain nothing had changed and everything was as it was left when the car was running, the crank and cam sensors where syncing, so thinking that it might be my coil packs or ignition amp ( as the spark did seem extremely weak ) I bought a new set of coil packs ( VAG 4 way logic coils x 2 ) and wired them up to give me sequential spark ( coil near plug ) still will not start.

 Next I checked that I was getting spark at the plugs via test mode, that was fine so was the injectors via test mode. fuel pressure was checked and that was steady at 44PSI and fuel was getting to the plugs because they where getting wet with fuel. I then decided to take apart the front of the engine to check that the woodruff key was fine and to also check the timing chain, these where found to be fine as well, after the engine was reassembled the compression was checked this to was fine, so next the crank shaft position sensor was changed ( and a new more adjustable mount fitted ) and then this was logged in tuner studio to double check that I was getting a good signal from both of the crank and cam sensors, both of these where fine with no sync errors.

 Next I reset my tooth No.1 position and tried to start the car again, nope still will not start in fact all it does is cough. I have tried to check the timing on cranking but the engine will not turn over fast enough to get a good reading with the strobe and no matter what I do with the cranking timing it still will not start.

 So at the moment I have totally stripped out all of the electrical system to do with the engine management and all of my additional fuse boxes and relays plus any wiring, when I feel in the mood I will redo the entire electrical system which will incorporate moving the battery to the boot and putting the Megasquirt, fuse boxes and relays to where the battery was ( to make wiring simpler and eliminate any errors which can occur ) but this may take a while as I have got to get on with the bodywork on the mustang while I have still got the weather.

 If anyone can think of anything that I have missed please let me know as frankly where the spit is concerned I am at my limit and the next thing that I might do is to send the Megasquirt back to the person I bought it from to be checked as I do not have the equipment to do this.

Share this post


Link to post
Share on other sites

You could make a log from the starting process with Megasquirt connected to the CPU.

If you like you may send it to me with the tunefile.

I think its more related to wrong fuel metering and misfire relates to bad plugs

that already will not fire due to earlier rich tuning.

Share this post


Link to post
Share on other sites

Well it is running again, after pulling the entire wiring loom and rewiring from scratch ( to no result ) it turned out to be my camshaft position sensor. The strange thing is that the sensor worked fine on the bench and when being tested on the car but it kept going wrong when you tried to make the car start, so I pulled out the optronic unit I was using and replaced it with a hall sensor and modified the trigger to suit.

 Now the car is running again I have now replaced my coil packs and gone coil near plug using VW coil packs, the only bugbear is that I fiddled with my fuel maps so much when trying to sort the problem out they are having to be done from scratch again and I have got to sort out the cold start settings again.

 The other thing I have done is to place the fuse/relay panel where the battery goes and the battery now lives in a battery box in the boot.

post-790-0-60918100-1443819066_thumb.jpg

post-790-0-74452500-1443819100_thumb.jpg

post-790-0-50432100-1443819134_thumb.jpg

post-790-0-99493400-1443819159_thumb.jpg

Share this post


Link to post
Share on other sites

The relays and fuses look nice but it was a total cow to wire up and to make sure that there was no mistakes.

 

 The coil packs are off a VW Golf/Jetta  also used on a Skoda Octavia, the part no is 06A905097 ( this is the part mentioned in the Megasquirt build manual ) I got these of Ebay for about £60 each but you can also get them from spares places like GSF but they cost about £90 - £110 each ( there is a slight fault in the molding of the ones I have got as if you put a bolt in the mounting hole nearest the plug lead connectors there is an arc to earth from the bolt but other than that they work fine ). The coil packs connection to the plug leads is a small 4mm pin connection and will require buying leads with this connector fitted ( expensive ) or you could do what I did and make your own leads, I got the components for making my leads from www.autoelectricsupplies.co.uk at a very good price.

 You will also need to buy a Bosch 6 way connector ( 1J0973726 - 6 way Sealed Female Connector ) to connect to the loom to the coil pack as these are nearly impossible to get second hand, trouble is these are nearly as hard to get new as well, I managed to source these from a german web site www.Automotive-connectors.com. The site is in german but can be switched to English via a toggle in the top right hand corner, the connectors can be bought with or without tails and cost about 8 euro's each plus postage.

Share this post


Link to post
Share on other sites

It has been a while since I last posted anything so I thought  I should update what has happened since I last updated.

 

 During 2016 the only changes I have made was to the gear stick set up as the original set fell apart leaving the gear change like stirring a pudding bowl ( this happened mid way through the London to southend charity run ). The setup now uses a rodend and a modified gearstick and should be bullet proof.

 

 Another job that has been done was to put the fuel injection pump in the tank, this required a surge baffle to be made and fitted so the pump did not suffer fuel starvation. I was planning to do this job next year but I thought that the old tank that was fitted to the car was leaking as every time I went to use the car ( which was once every couple of weeks ) the tank was almost empty and when I left the car it was normally left with at least half a tank plus the car was always stinking of fuel.

 When I removed the tank I could not find any evidence of leaking ( plus the fuel lines could not be leaking as the tank fuel outlet had a shut off valve fitted ) I began to suspect that someone might be helping themselves to the fuel when the car was not being used, this would not be the first time this had happened as two of my previous cars have had the fuel lines torn out and the tanks drained ( a couple of old fords ) and we suffer a lot of kids riding around on motorbikes around where I live.

 With this in mind I have fitted a locking fuel cap to the spit and within 5 days of fitting it I have noticed that someone has had a go of opening the locking cap as the cap had been pulled around and was sitting pissed but had not been opened. This has now been put back in place and I will have to keep a closer eye on it, the annoying thing about this is that someone has had to come up the drive almost to the front door to do this.

 

 Now this has been sorted out the car has developed a new fault in that it will not turn of once started even if I remove the leads from the battery the only thing I can think of is that there is a wiring fault ( possibly a bad earth )  as the only thing I have touched is that I have removed the lift pump relay and fuse and if I put the relay back the car works normally.

 

 

post-790-0-31600700-1489530954_thumb.jpg

post-790-0-36455300-1489531003_thumb.jpg

post-790-0-75952000-1489532895_thumb.jpg

post-790-0-00970100-1489532937_thumb.jpg

post-790-0-55960500-1489532966_thumb.jpg

post-790-0-55912800-1489532995_thumb.jpg

post-790-0-16314400-1489533017_thumb.jpg

Share this post


Link to post
Share on other sites

nice to hear you are still at it,..

 

as to your problem it sounds like the ECU and fuel pump(s) are getting a power feed direct from the alternator,you need to find the common bridge connection.

what relay format is it?

simple on/off,...change over,...double pole throw etc?

Share this post


Link to post
Share on other sites

I swear that this car is getting a strop on as I have not been doing much to it lately because I have been spending all my time on the mustang, the reason for me saying this is that last weekend ( Saturday ) I had got the spit out and taken it for a run filled it up and then washed it and cleaned it up as I was going to a show on Sunday ( Bromley Pagent of Motoring ). The thing is that when I went to put it away the XYZ'ing thing would not start ( this was at nearly seven in the evening and I had to be up at six in the morning ), the car turned over no problem but would not catch so the plugs where checked and they had no fuel, so the injection line was checked and no fuel was found but the pump was working so I thought that it might be a filter problem so that was checked still no fuel was found at the filter.

 This left only the pump but you could hear it working, then I remembered reading one of the other members posts on the forum about the fuel pipe coming adrift in the tank, so this meant removing the tank to check it out ( this is at almost half seven at night ). After pulling the tank out ( which was full of fuel ) and removing the pump setup the pipe had indeed fallen off the out put pipe, this had happened because of several factors :

 

1. me being lazy and forgetting to put a flare on the copper out put pipe.

2. the rubber fuel pipe softening at the pipe clamp allowing the pipe to slip off ( even though it is R9 rated ).

3. using a small pipe clamp to hold the rubber pipe on.

 

 So to fix this I had to make a flare by hand on the copper pipe then cut back the rubber pipe to where it was firmer and use a better pipe clamp then fit the pump back in the tank then put the tank back in the car ( total time to take the tank out and put it back 1 hour so not to bad ). You would think that this would be the end of the problems but no, the car still would not start it and seemed that there was a air lock in the fuel system around the injectors but after cranking it for a while it finally started and the car finally put away for the evening. The next morning I got the car loaded up for the show went to start it, and you guessed it the air lock was back so I spent another quarter of an hour cranking the car to get the air lock to shift and then the car managed to start.

 The car drove to the show no problem got a bit hot in traffic but that was it, the real test came when it was time to leave the show, would it start, thankfully it did at the first touch of the start button. So I think I am going to have to spend a day going over the car in the next day or so to check for any other problems as I have few more shows coming up over the next few months and I am intending to use the car itself for some running around as I do not use it enough at the moment.

 

P.S. I have also found that J.B.Weld is not fuel proof.

Share this post


Link to post
Share on other sites

then I remembered reading one of the other members posts on the forum about the fuel pipe coming adrift in the tank

 

 

That was me.... :yes:

 

As I discovered the outer layer of R9 fuel line is not designed to be submerged in fuel, so bought a length of this: https://www.merlinmotorsport.co.uk/p/rubber-in-tank-fuel-hose-by-cohline-per-metre-2190-0615 which says it is. It's only been on a few weeks, so time will tell if it's up for the job.

 

Darren

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×